Library conflicts

From Dynamo
Jump to: navigation, search

Here we will list some of the problems found when installing/activating Dynamo.

Conflicting libstdc installations

Problem Some programs (specially the core of the GPU computations) cannot link to GLIBCXX.3.4.21 or some other number. This might happen both in Matlab or standalone modus.

Solution

Type in your linux shell

LD_PRELOAD="/usr/lib/x86_64-linux-gnu/libstdc++.so.6" 

or, correspondingly for bash shell

 export LD_PRELOAD=/usr/lib/x86_64-linux-gnu/libstdc++.so.6

(or the equivalent in your system) before starting Matlab (or Dynamo in the standalone)

Graphic depiction problems in the standalone

Some systems report a conflict when trying to generate graphical output in the Linux standalone:

Error using axes
While setting property 'Parent' of class ''Axes'':
Can't load '<your installation path>/MCRLinux/bin/glnxa64/libmwosgserver.so': dlopen: cannot load any more object with static TLS

These kind of errors can be solved by preloading the library before calling the Dynamoconsole by dynamo

 export LD_PRELOAD=<your installation path>/MCRLinux/bin/glnxa64/libmwosgserver.so

Characters appear as blocks in the GUIs

Problem

Some or all elements in a GUI don't show text characters. In place of text characters, empty square blocks are shown.

Solution Install the dejavu-fonts package in your Linux system.